FREEDOM. FRIENDS. FEATURES. FIRST.
페도라 한국 사용자 모임

'modutils 2.4.3 을 설치하고 있는데 make 과정에서 오류가 납니다.'에 답변달기

게시판 질문게시판 modutils 2.4.3 을 설치하고 있는데 make 과정에서 오류가 납니다. 'modutils 2.4.3 을 설치하고 있는데 make 과정에서 오류가 납니다.'에 답변달기

#15413
난해주님
참가자
  • 게시글114
  • 댓글337
  • 총합451
  • ★★
@workman729

아래 페이지를 참조해서 의존성을 체크 하신 후 다시 시도해 보십시오.
make 과정에선 최신 버전의 binutils가 필요 하므로 체크해 보시기 바랍니다.

http://archive.linuxfromscratch.org/lfs-museum/5.1-pre1/LFS-BOOK-5.1-PRE1-HTML/chapter06/modutils.html

obj_kallsyms.c:206: error: lvalue required as left operand of assignment

위의 문제는 아래 패치를 적용하여 gcc-4.0으로 업그레이드 하여 make 하시기 바랍니다.
패치는 아래 링크를 참조 하십시오.

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=282672