FREEDOM. FRIENDS. FEATURES. FIRST.
페도라 한국 사용자 모임

업데이트 할때 transaction error 나타나요

게시판 질문게시판 업데이트 할때 transaction error 나타나요

  • This topic has 2개 답변, 2명 참여, and was last updated 10 years, 9 months 전에 by 가리비x99. This post has been viewed 19 times
  • 만든이
    게시글
  • #13221
    가리비x99
    참가자
    • 게시글4
    • 댓글8
    • 총합12
    • ★★
    @scallop99

    따로따로하면 되긴 되는데.. 번거로워서; 업데이트 잘못하니까 파일매니저 막 뜨면서 부팅이 안되서 재설치했음

     

    콘솔모드로 yum [-y] update 해주면 전체설치 된다는데.. 아무래도 잘못된 명령어 같아요

     

    왜 한꺼번에 안되고 저런 오류가 뜨죠?; 인터넷에서 찾아봐도 해결방안이 안나와서 써봅니다..;

     

    알려주세요 ㅠ

    ^^

1 답변 글타래를 보이고 있습니다
  • 글쓴이
    답변
    • #14695
      rOutitz
      참가자
      • 게시글13
      • 댓글21
      • 총합34
      • ★★
      @routitz

      yum 명령어 중에 update와 관련해서 자주 쓰이는 것들이 대충

      • yum check-update - 업데이트 가능한 패키지를 죽 다 보여줍니다.
      • yum update  - 업데이트 가능한 패키지를 모두 업데이트 합니다.
      • yum update [패키지 이름] - 지정한 패키지만 업데이트 합니다.

      여기에 -y를 더해주시면 [y/N]를 묻는 질문에 무조건 y로 대답하니까 중간에 확인 안 하고 업데이트 하는거죠.
      명령어는 yum update가 완벽하게 맞습니다.

      정확하게 어떤 transaction 에러인지는 모르겠는데, 따로따로 업데이트하면 된다고 하시는 걸 봐서는 아마도
      업데이트 가능한 여러 패키지 중에 한 두 개에 의존성 문제가 걸려 있고, 그때문에 업데이트가 안 되고 있는
      것 같습니다.

      예를 들면 이 비슷한 메세지가 나오지는 않던가요?

      file [xxx] from install of <xxx> conflicts with file from package <yyy>

      질문하실 때는 관련 메세지를 통채로 써주시는 게 좋아요 ㅎㅎ

    • #14696
      가리비x99
      참가자
      참가자
      • 게시글4
      • 댓글8
      • 총합12
      • ★★
      @scallop99

      감사합니다~ 콘솔모드로 하니까 어찌어찌 잘 되는거 같네요 ㅎㅎ ㄳㄳㄳ

      ^^

1 답변 글타래를 보이고 있습니다
  • 답변은 로그인 후 가능합니다.