FREEDOM. FRIENDS. FEATURES. FIRST.
페도라 한국 사용자 모임

fedora17에서 gcc downgrade 하는방법이 궁금합니다.

게시판 질문게시판 fedora17에서 gcc downgrade 하는방법이 궁금합니다.

  • This topic has 2개 답변, 3명 참여, and was last updated 7 years, 10 months 전에 by 냠냠. This post has been viewed 23 times
  • 만든이
    게시글
  • #13529
    아돌
    참가자
    • 게시글3
    • 댓글1
    • 총합4
    • ★★
    @adol213
    다운그레이드 관련 질문입니다. gcc를 4.7 버젼으로 쓰고 있는데, 낮은버젼으로 컴파일을 해야 하는 상황이 생겼습니다. 물론 검색을 해보았는데, 페도라의 경우 'yum install compat-gcc-버전' 이렇게 입력하라고 다수 홈페이지에서 나옵니다. 그런데 안됩니다.... ..  그래서 질문합니다.

    gcc를 다운그레이드 하는 방법들을 알려주시면 감사하겠습니다. 실질적으로 되는 방법을 알려주시면 감사하겠습니다. 

    yum으로 gcc 지우고, rpm으로 설치를 하는 작업을 거쳐야 하는건지...

    리눅스 배포판 : Fedora 17
    커널버젼 : Linux 3.6.11-1.fc17.x86_64
    gcc 버젼 : gcc (GCC) 4.7.2 20120921 (Red Hat 4.7.2-2)

    지금은 리눅스 C언어를 배우고 있어요. 정확하게는 TCP/IP 소켓프로그래밍 쪽을 공부하고 있습니다.


     


    나중에 임베디드시스템을 공부할때 페도라가 많이 사용될꺼 같아요


     


    많이 부족하지만, 열공할께요.


     


    모두 화이팅~

1 답변 글타래를 보이고 있습니다
  • 글쓴이
    답변
    • #15235
      난해주님
      참가자
      • 게시글114
      • 댓글337
      • 총합451
      • ★★
      @workman729

      compat-gcc는 fedora release repo에 파일이 있습니다.

      yum으로 설치하시면 됩니다. 정히 패키지를 찾지 못하겠으면 소프트웨어 설치를 통해 검색해 보십시오.
      컴파일시 해당 gcc 버전을 사용하기 위해선 컴파일 하시려는 프로그램의 인스톨 문서 또는 readme 문서를 통해 옵션을 확인해 보십시오.
      또는 ./configure --help를 통해 옵션을 확인 하실 수 있습니다. 프로그램 마다 옵션이 조금씩 다를 수 있습니다.
    • #15236
      냠냠
      참가자
      • 게시글2
      • 댓글4
      • 총합6
      • ★★
      @nhamfnad

      저도 찾아보니 gcc 3.4 버젼은 yum 으로 설치가 가능하네요.

      터미널에서 다음 명령으로 설치하시고..
      yum install compat-gcc-34
      yum install compat-gcc-34-c++

      실행은
      gcc34

      혹은
      g++34

      명령으로 컴파일 가능합니다만...

      오래된 프로그램을 컴파일 하려면 또한 관련된 오래된 라이브러리들도 같이 필요하므로 컴파일에 어려움이 예상됩니다.
      아예 해당프로그램이 잘 동작했던 옛버전의 리눅스배포판을 virtualbox 상에 설치해서 작업하는것도 한가지 방법이겠죠..

1 답변 글타래를 보이고 있습니다
  • 답변은 로그인 후 가능합니다.